[chef-dev] Re: omnibus-chef/jenkins/release.rb script

Chronological Thread 
  • From: Ryan Hass < >
  • To: " " < >
  • Subject: [chef-dev] Re: omnibus-chef/jenkins/release.rb script
  • Date: Tue, 08 Sep 2015 22:17:32 +0000

I figured out that I overlooked the chef-platform-names.json file, as I had thought it was auto generated.


I suspect the other json file is empty because I left out the fedora mapping, but I will need to check that tonight when I get home. Nevertheless, any pointers in getting the builds recognized by my omnitruck instance would be appreciated.

-Ryan H.

On Mon, Sep 7, 2015, 11:48 PM Ryan Hass < "> > wrote:
I am working on setting up an omnitruck instance to provide ARM builds of Chef and other bits for a handful of OSs. I was wondering if someone might be able to give me a better understanding of some of the expectations of the script.

I have gotten as far as having it push a chef-platform-names.json and a chef json to chef-release-manifest in my chef-arm bucket -- but I am having issues both of these files. The chef-plaform-names.json I expected to be generated from the contents of chef.json in the jenkins directory, but it contains basically all the standard platforms and not the ones I put into the file; and with the latter as it seems to be an empty json block.

Here is what I ran:

bundle exec ./release.rb -p chef -b chef-arm -M chef-arm -m ~/.s3cfg -v 12.5.0-current --ignore-missing-packages

In the directory above the current working directory where the script being run, I placed the following files which I generated from omnibus-chef:




I tried using '-v 12.5.0~current.0+20150907225631.git.302.dc1686f-1' and '-v 12.5.0~current.0+20150907225631' which yielded the the same results. Any help I can get would be appreciated. Thanks!

-Ryan H.

Archive powered by MHonArc 2.6.16.