- From: Daniel DeLeo <
- Subject: [chef] Re: Re: Re: Re: chef-server 0.8.6 requires rubygems version >= 1.3.6?
- Date: Fri, 26 Mar 2010 09:56:25 -0700
As Joshua said, the issue is with merb 1.1.0, which we don't yet
support. Unfortunately, Chef's gemspec only specifies that it
requires 'merb' and does not specify any version constraints, so
when you 'gem install chef-server' (for example) rubygems will grab
the newest available version of merb. We are tracking the issue as
CHEF-1064, for which I have created a patch, so I believe the
next release of Chef will not have this problem.
In the meantime, you can fix the issue by installing merb 1.0.15. You
must also uninstall merb 1.1.0 if it is installed.
1) Merb is split up into lots of piecemeal gems. Chef specifically
requires merb-core, merb-assets, merb-helpers, merb-haml, and
merb-param-protection, all at version 1.0.15
On Fri, Mar 26, 2010 at 8:18 AM, Joshua Timberman
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> On Mar 26, 2010, at 1:22 AM, Ringo De Smet wrote:
>> Still, the wiki mentions to install rubygems 1.3.6.
>> One might believe that the minimum required version needs to be 1.3.6.
>> With respect to ticket CHEF-63, I double-checked which version of
>> rubygems comes with Karmic & Lucid:
>> Both distributions come with rubygems 1.3.5.
>> Shouldn't the chef-server installation work with this version?
> The version of Merb in the Debian/Ubuntu packages is 1.0.12, and doesn't use
> bundler. With Merb version 1.1.0, bundler is an added dependency, and
> bundler requires RubyGems 1.3.6.
> - --
> Opscode, Inc
> Joshua Timberman, Senior Solutions Engineer
> C: 720.334.RUBY E:
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.10 (Darwin)
> -----END PGP SIGNATURE-----
Archive powered by MHonArc 2.6.16.