[chef] Re: Is search broken?

Chronological Thread 
  • From: Maven User < >
  • To: chef < >
  • Subject: [chef] Re: Is search broken?
  • Date: Fri, 28 Oct 2011 15:21:31 -0400

I've created a new role "foo".

It's blank (no cookbooks/recipes associated with it).

I've added that role to a node's runlist.

but It's still not showing up as a role:

C:\chef>knife node show coolserver
Node Name:   coolserver
Environment: _default
FQDN:        coolserver.coolcompany.com
Run List:    role[somerole], role[someotherrole]
Roles:       somerole
Recipes:     coolrecipe
Platform:    windows 6.1.7601

Even in its current state:

knife search node "role:somerole"

doesn't work (returns "0 items found").

Any suggestions?  This totally takes knife-based-deployments out of the equation for us...

On Wed, Oct 26, 2011 at 4:25 PM, Maven User < "> > wrote:
Hi all -

I'm now trying to do some knife work and when I do this:

C:\chef>knife node list -c c:/chef/client.rb -E dev01

(just one result - which is expected)

I get one thing, but when I run the search:

knife search node "chef_environment:dev01 and node_name:<somedev01node>" -c c:/chef/client.rb

I get back every node including things in the "_default" environment.

What am I doing wrong?

Archive powered by MHonArc 2.6.16.