[chef] Re: can't activate eventmachine (~> 0.12.10, runtime) for ["chef-expander-10.14.2"]

Chronological Thread 
  • From: James Light < >
  • To:
  • Subject: [chef] Re: can't activate eventmachine (~> 0.12.10, runtime) for ["chef-expander-10.14.2"]
  • Date: Thu, 27 Sep 2012 21:28:57 -0400

Yea, I ran into that and at least one other person in the IRC room on Freenode did (the logs of which were where I found the answer that worked for me).
We both had two versions of the eventmachine gem installed.
Uninstalling both and then installing the lowest version that satisfied the dependency tweeted in the error message fixed the issue for me.
Not sure exactly what process the other person used, but that worked for me.

On Sep 27, 2012 3:11 PM, "Julian C. Dunn" < "> > wrote:
I'm testing Chef 10.14.2 in a Vagrant VM on CentOS 6. Has anyone seen
the above error before? I put the full error on Gist:

I'm using the chef-server::rubygems-install recipe from the opscode-cookbooks.

- Julian

Archive powered by MHonArc 2.6.16.