[chef] Re: Re: Re: Re: opscode nagios quick start

Chronological Thread 
  • From: Daniel DeLeo < >
  • To:
  • Subject: [chef] Re: Re: Re: Re: opscode nagios quick start
  • Date: Mon, 31 Dec 2012 10:46:46 -0800

On Monday, December 31, 2012 at 7:58 AM, Tim Dunphy wrote:

hey guys.. yes as Jesse pointed out I was using an outdated validation.pem at /etc/chef/validation.pem as referenced by my knife.rb. I actually realized this when I noticed in a test run I did this morning was referencing that file and failing to apply the roles I had specified on the command line.

So I tried doing a 'diff' on /etc/chef/validation.pem and /Users/dunphy/.chef/validation.pem and noticed that I recognized the cert in /etc/chef as the one that i saw in /etc/chef/validation.pem on the ec2 instance that I created last night and failed. So, similar to what Jesse suggested I copied the cert I had at .chef/validation.pem to /etc/chef/validation.pem and *voila*! SUCCESS! I tried this before I saw Jesse' reply but I certainly appreciate both your input. I would certainly have pulled what remains of my hair out trying to figure this out had I not stumbled onto the answer myself or been advised of the right one.

Thanks again guys!

FWIW, I wrote a key checker knife plugin. I probably ought to clean it up and add tests so it could be added to chef proper. 

I developed it against Opscode Hosted Chef, and haven't had an opportunity to test against the open source server, though I believe it should work. 


Daniel DeLeo

Archive powered by MHonArc 2.6.16.