[chef] Re: Running bundle install

Chronological Thread 
  • From: Akzhan Abdulin < >
  • To:
  • Subject: [chef] Re: Running bundle install
  • Date: Fri, 18 May 2012 09:45:35 +0400

bundle install --deployment

2012/5/18 Justin Louie < " target="_blank"> >
Hi All,

I've tried to no avail to make bundle install work on a Vagrant box. Currently the process is:
  1. Get ruby using ruby_build OR direct compile and install
  2. Obtain code from git via deploy.
  3. Run recipe:
script "bundler install" do
  interpreter "bash"
  user "ubuntu"
  cwd deploy_dir + "/current"
  code <<-EOH
bundle install

The response is usually "Errno::EACCES: Permission denied - /root/.bundler". All the tinkering of settings won't allow me to properly run bundle install. I've tried
  • --path
  • different users
  • ruby_build vs rvm vs direct compile and install
If I login to ubuntu or vagrant and run bundle install manually, everything works great.

Any help would be much appreciated as I've been banging my head against this for the past 6 hours.

Chef is 0.10.8
Ruby is 1.9.3-p194


Archive powered by MHonArc 2.6.16.